Wij gaan door tot jij 100% tevreden bent

De technische experts van onze bekroonde klantenservice staan voor je klaar!

Welke PHP-versie kan ik het beste kiezen?

Het is belangrijk om goed na te denken over de PHP-versie die je gebruikt. De laatste PHP-versie heeft namelijk belangrijke voordelen, zoals meer snelheid, meer functionaliteit en minder belasting op je beschikbare resources. Kies daarom altijd voor de laatste PHP-versie als je website het toelaat. 

De beste keuze

Hieronder zie je per CMS welke PHP-versie je het beste kunt kiezen. Daarbij wordt ervan uitgegaan dat je de meest recente versie draait.

  • WordPress: PHP 8.0
  • PrestaShop (1.7 of nieuwer) : PHP 7.1
  • Magento: PHP 7.2
  • Drupal (8.8.3 of nieuwer): PHP 7.4
  • Joomla (3.5 of nieuwer): PHP 7.4
  • Joomla (2.x en 3.x): PHP 5.6

PHP-versie wijzigen

Dankzij de PHP-selector binnen DirectAdmin kun je heen en weer schakelen tussen PHP-versies. Zo kun je bijvoorbeeld gemakkelijk testen of bepaalde onderdelen van je website goed draaien.

Kies achter 'Current PHP version' via het uitklapmenu de gewenste PHP-versie.

Voordat je van PHP-versie verandert, is het belangrijk om te controleren of jouw website of applicatie wel ondersteuning biedt voor het gebruik van de gekozen PHP-versie.

Treed er onverwacht toch een probleem binnen je website op, wanneer je naar andere PHP-versie overschakelt? Je kunt dan altijd weer terugschakelen naar de eerder ingestelde versie. Nadat je probleem het hebt opgelost, kun je dan weer naar de nieuwere versie overstappen.

PHP 5.3 t/m 7.2 - end of life

Op 14 augustus 2014 heeft PHP 5.3 de status end of life van de ontwikkelaars toegekend gekregen. Voor PHP 5.4 gebeurde dat op 3 september 2015 en voor PHP 5.5 op 21 juli 2016. In feite worden vanuit PHP momenteel PHP-versies ouder dan 7.3 niet langer ondersteund en geüpdatet. Eventuele bugs en beveiligingslekken in deze versies worden niet meer opgelost of gedicht.

PHP 7.3 krijgt in 2021 nog beveiligingsupdates, maar wordt niet verder ontwikkeld. Als je nu nog een versie ouder dan PHP 7.3 gebruikt, dan is het sterk aan te raden om over te stappen op een nieuwere versie. Zo zorg je ervoor dat je website veiliger, sneller en efficiënter is. Overstappen kan eenvoudig via de PHP-selector in DirectAdmin.

Standaard PHP-versie

Als je bij ons een nieuw hostingpakket hebt besteld, dan wordt dit op het moment standaard met PHP 7.4 opgeleverd. Je hebt bij ons echter zelf de vrijheid om te bepalen welke PHP-versie je graag wilt draaien.

Wil je liever een oudere PHP-versie gebruiken, dan kun je dit wijzigen via de PHP-selector. Andersom geldt hetzelfde: draai je een oudere PHP-versie en wil je over op een nieuwere versie, dan kun je dat eenvoudig aanpassen in DirectAdmin.

 

Sterren Domeinnaam: 5 sterren uit 5.118 reviews

320.000+ domeinnamen geregistreerd
Bij de beste registrars in MT1000 en Emerce 100

Geen cookies