WordPress 5.0 Bebo is uit: Gutenberg of Classic Editor?

WordPress heeft op 6 december versie 5.0 van hun razendpopulaire CMS uitgebracht. Een belangrijke mijlpaal! De update bevat onder andere een gloednieuw standaardthema (Twenty Nineteen) en de niet onomstreden Gutenberg Editor. Deze op blokken gebaseerde editor moet het maken van posts flink vergemakkelijken. Waar op te letten als je gaat updaten?

WordPress 5.0 is nu beschikbaar: Gutenberg of Classic Editor?

Eén van de grootste wijzigingen is dat Gutenberg de huidige standaard editor in WordPress vervangt. In plaats van de WYSIWYG & HTML editor die bij berichten en pagina’s werd weergegeven, wordt het bewerken van content met Gutenberg via een soort blokkensysteem gedaan (een nieuw soort WYSIWYG). Je kunt dat hier uitproberen om daar een beeld van te krijgen.

Updaten naar WordPress 5.0

Als je naar WordPress 5.0 gaat updaten, dan is het handig om te beslissen welke editor je wilt gaan gebruiken. Stap je over naar Gutenberg of blijf je bij de vertrouwde, klassieke editor? Dat laatste is namelijk ook gewoon mogelijk! WordPress blijft tot 2021 de Classic Editor ondersteunen.

WordPress 5.0.1
WordPress heeft op 13 december versie 5.0.1 uitgebracht. Dit is een beveiligingsupdate. Voer de update daarom zo snel mogelijk uit.

Overstappen naar Gutenberg

Wil je Gutenberg gaan gebruiken, maak dan eerst even een backup voordat je gaat updaten. Dat kan gemakkelijk via Installatron of DirectAdmin. Gaat er iets mis, dan kun je snel terug naar een werkende situatie. Heb je een Slim-, Plus- of Pro-pakket, dan kun je dit overslaan. Daar maken wij namelijk al proactief backups die je zelf via Antagonist Backups in DirectAdmin eenvoudig terugzet.

De Gutenberg editor in WordPress.

De Classic Editor behouden

Mocht je Gutenberg voor jouw WordPress-website (nog) niet actief willen gebruiken, installeer dan de plugin Classic Editor na het updaten. Zo kun je nog gewoon van de oude, bekende editor gebruikmaken. Je vindt deze plugin via je WordPress-dashboard (Plugins → Nieuwe toevoegen → zoek op ‘Classic Editor’) of download hem via de pluginpagina en installeer het handmatig.

De Classic Editor-plugin voor WordPress.

Ondersteuning voor PHP 7.3

WordPress 5.0 ondersteunt nu ook officieel PHP 7.3 – bij ons al een tijdje beschikbaar! Gebruik je nu nog een oudere PHP-versie, dan raden zij (en wij) sterk aan over te schakelen. Via de PHP-selector in DirectAdmin heb je dat zo geregeld. Je website wordt er sneller en efficiënter van.

Als je over wilt naar PHP 7.3, zorg dan dat je de laatste versie van WordPress draait. Merk op dat plugins en thema’s die je gebruikt ook PHP 7.3 moeten ondersteunen. Werkt je website na het overschakelen niet juist, ga dan weer terug naar de voorgaande PHP-versie. Controleer vervolgens de error log om te achterhalen waar binnen je website de oorzaak zit.

Release notes | Check voor meer informatie over alle wijzigingen in WordPress 5.0 zeker even de release notes. Daar vindt je ook duidelijke video’s die verschillende features van de nieuwe editor uitleggen.

Met WordPress beginnen?

Wil je graag zelf met WordPress aan de slag? Dat kan! We hebben een handig stappenplan beschikbaar. Daarmee heb je WordPress binnen een paar klikken op je hostingpakket geïnstalleerd.

WordPress installeren →

P.S. Wil je op de hoogte blijven van alle artikelen, updates, tips en trucs die verschijnen op ons blog? Dat kan! Rechts bovenin via RSS, e-mail, het liken op Facebook, het +1’en op Google+ of het volgen op Twitter.

Deel Tweet +1 Deel