Welke PHP-versie kan ik het beste kiezen?

Het korte antwoord: op het moment van schrijven (23 september 2015) versie 5.6. Als PHP 7.0 rijp is voor productie, dan moet je overschakelen naar deze versie. Einde blog…

Welke PHP-versie kiezen: PHP upgrade

Natuurlijk is het niet altijd zo gemakkelijk. Als het zo simpel was, dan zouden we al onze klanten altijd van de beste PHP-versie gebruik laten maken. De realiteit is echter anders. Zodoende is het niet verstandig om zomaar over te stappen naar de laatste versie, zonder na te gaan of dit voor problemen zorgt.

Je pakket kan bijvoorbeeld gebonden zijn aan een specifieke PHP-versie, omdat je website die vereist. Ook als je een site zelf hebt gebouwd, dan kan het zijn dat er functies worden gebruikt die niet meer ondersteund worden of op andere manier zijn geïmplementeerd. Daarom kun je bij ons ook zelf kiezen welke PHP-versie je gebruikt.

Maar wacht! Moet je dan altijd een versie kiezen? Nee, wij stellen voor ieder nieuw pakket de laatste stabiele PHP-versie als standaard in. Op dit moment is dat PHP 5.6 en dat wordt vanzelf PHP 7.0, als deze versie stabiel en geschikt wordt bevonden.

Welke PHP-versies zijn er?

Bij Antagonist worden momenteel vijf verschillende versies aangeboden: van PHP 5.3 tot en met PHP 7.0. Laten we eens kijken naar die versies in de volgende tabel.

Welke PHP-versie kiezen: PHP support table

Zoals je kunt zien, zijn er op dit moment Twee versies (5.3 en 5.4) die niet meer worden onderhouden door php.net. Voor één versie (5.5) komen enkel nog security-updates, één versie (5.6) is momenteel de actieve release en als laatste is er één versie (7.0) die bijna klaar is voor productie.

Is het onveilig om een oude PHP-versie te gebruiken?

Zoals je hierboven hebt kunnen zien, komen er sinds 14 augustus 2014 geen beveiligingsupdates uit voor PHP 5.3. Zelfs niet voor lekken die sindsdien zijn gevonden. Het gaat hier echter puur om de support die php.net levert. Omdat PHP open source is, kan iedereen die dat wil zelf beveiligingsupdates toepassen op PHP 5.3. Dit noemt men ‘security patches backporten’. Op ons platform maken wij ook gebruik van PHP 5.3 en 5.4 met beveiligingsupdates, dus je hoeft je wat dat betreft geen zorgen te maken als je één van deze PHP-versies wilt gebruiken.

Welke reden is er dan wel om over te stappen?

Hier zijn verschillende redenen voor aan te dragen. De belangrijkste twee zijn functionaliteit en snelheid. In elke versie van PHP worden nieuwe functionaliteiten toegevoegd die het weer gemakkelijker maken om bepaalde taken uit te voeren. Gebruik je de laatste versie, dan heb je dus de meeste functionaliteit tot je beschikking.

De andere reden is snelheid. Laten we eens kijken naar de volgende plaatjes.

Welke PHP-versie kiezen: PHP 7 benchmark WordPress

Welke PHP-versie kiezen: PHP 7 benchmark Drupal

Zoals je ziet, is PHP 5.3 verreweg de traagste PHP-versie. Met PHP 5.4 is daar wat verbetering in gekomen. In het plaatje lijkt het niet veel, maar het gaat toch om 20% snelheidswinst. Ook met de komst van PHP 5.6 is er een kleine snelheidswinst behaald. Beide vallen echter in het niet als je het vergelijkt met PHP 7.0. Dit zorgt voor ongeveer een verdubbeling van de snelheid!

Iedereen naar PHP 7!

Voordat iedereen nu enthousiast zijn PHP-versie naar 7.0 zet, vanwege de beloofde snelheidswinst, ik benadruk nogmaals dat PHP 7.0 op dit moment niet geschikt is voor productie. Natuurlijk mag je zelf kiezen om de versie toch te gaan gebruiken, maar houd er rekening mee dat je website dan plotseling stuk kan gaan. Terugschakelen naar een oudere versie lost dit dan natuurlijk direct op. Vanaf eind november wordt PHP 7 als stabiel gemarkeerd en is overstappen zeker de moeite waard!

Welke PHP-versie kiezen: PHP 7 selector warning

Zoals je in bovenstaand plaatje kunt zien, wordt je op dit moment gewaarschuwd wanneer je PHP 7.0 wilt inschakelen.

Wat als je website niet met een nieuwe PHP-versie werkt?

Je kunt om te testen ook een andere PHP-versie inschakelen voor een bepaalde map door middel van een regel in de ‘.htaccess’. Als voorbeeld heb je jouw website in ‘public_html’ staan. Deze werkt alleen met PHP 5.3. Nu wil je jouw website verbeteren, zodat deze ook met PHP 7 werkt. Echter,  wanneer je de PHP-versie omzet, is je website stuk. Wat je dan kunt doen, is je nieuwe versie in ‘public_html/new’ zetten. In deze map zet je dan vervolgens een .htaccess met de volgende inhoud:

AddType application/x-lsphp70 .php5 .php4 .php .php3 .php2 .phtml

Vanaf nu zal de inhoud van deze directory door PHP 7 worden afgehandeld, zo simpel is het! Werkt je nieuwe site goed, dan vervang je de oude website door de nieuwe en pas je de PHP-versie aan binnen DirectAdmin. Nog nooit was het overschakelen naar een nieuwe versie zo gemakkelijk.

Welke PHP-versie kiezen: leuker kunnen we het niet maken

Samengevat

Doordat er nog veiligheidsupdates uitkomen voor oude PHP-versies, is er geen urgente reden om over te stappen naar een nieuwe versie van PHP. Toch zijn er genoeg voordelen te benoemen om dit wel te doen. Daarnaast is het testen met een nieuwe versie uiterst eenvoudig. Er zijn dus weinig redenen om niet te updaten. Ik verwacht dan ook een ware verschuiving in gebruikte PHP-versies bij onze klanten. Wat houdt jou nog tegen? We hebben trouwens deze handleiding voor het kiezen van je PHP-versie.

Nieuwsgierig welke andere features en specificaties bij Antagonist gelden?

Bekijk hostingpakketten →

P.S. Wil je op de hoogte blijven van alle artikelen, updates, tips en trucs die verschijnen op ons blog? Dat kan! Rechts bovenin via RSS, e-mail, het liken op Facebook, het +1’en op Google+ of het volgen op Twitter.

Deel Deel Deel Deel

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *