Schakel over naar PHP 5.5

Over naar PHP 5.5Het overgrote deel van de websites op het internet, en zo ook bij Antagonist, maakt gebruik van PHP. Eerder dit jaar, in een blogpost van Wouter, spraken we over de introductie van een nieuwe techniek bij Antagonist; de PHP-selector. Deze nieuwe tool maakt het gebruik van PHP veel uitgebreider en flexibeler.

Inmiddels draait de PHP-selector al een tijdje bij Antagonist, en met groot succes! Sinds de aankondiging hebben we van een heleboel klanten enthousiaste berichten ontvangen en zijn vele accounts overgegaan op een nieuwe versie van PHP. De tool stelt gebruikers namelijk in staat om zelf te bepalen welke PHP-versie het hostingpakket, en daarmee dus ook de website, gebruikt.

Maar is het niet alleen voor techneuten?

Wellicht dat velen van jullie nu denken: dit is een prachtige oplossing voor techneuten; een ontwikkeling bedoelt voor developers die graag het nieuwste van het nieuwste gebruiken. Dat klopt natuurlijk volledig.

Echter, juist ook voor een beginnende of doorsnee gebruiker is het verstandig om de mogelijkheden, die de PHP-selector biedt, te verkennen. Simpelweg, omdat je met behulp van de PHP-selector eenvoudig kunt overschakelen naar een nieuwere versie van PHP. Daarbij kun je tevens de instellingen configureren waardoor je website mogelijk sneller, stabieler en veiliger wordt.

Over naar PHP 5.5: niet alleen voor techneuten

Stel je hebt een website en die gebruikmaakt WordPress of Joomla, dan wordt er automatisch ook gebruik gemaakt van PHP. Om meer uit je website te halen en je daarbij te helpen, wijden wij dit artikel aan het ‘hoe en waarom’ die hierachter schuilt gaat.

PHP 5.3 ‘End of life’

Sommigen zullen wellicht gehoord hebben dat op 14 augustus 2014 PHP versie 5.3 de status ‘End of life’ heeft gekregen van haar ontwikkelaars. Dit betekent dat PHP 5.3 niet langer wordt onderhouden. Nou wil dit niet zeggen dat PHP 5.3 ineens ophoudt te werken.

Het houdt echter wel in dat wanneer er nog bugs, problemen of ‘vulnerabilities’ ontdekt worden, deze niet langer door de ontwikkelaars worden verholpen in een nieuwe 5.3 release. In de praktijk houdt dit in dat het verstandig is om zeer serieus te overwegen over te stappen op een nieuwere versie van PHP, tenminste als je nu nog van PHP 5.3 gebruiktmaakt.

Snelheidswinst en geheugengebruik

Het verschil tussen de beschikbare PHP versies in de PHP-selector is niet beperkt tot een versienummer en de mate van actieve ontwikkeling. Er zit ook een fors merkbaar prestatie-verschil tussen de beschikbare versies. Zo kan, afhankelijk van de website en opzet, een toename in performance van 20% tot 40% worden behaald, en dat enkel door over te schakelen van het verouderde PHP 5.3 naar bijvoorbeeld PHP 5.5!

Over naar PHP 5.5: performance boost

Maar dat is nog niet alles. Ook de hoeveelheid werkgeheugen dat PHP gebruikt is drastisch gedaald tussen versies PHP 5.3 en 5.5. Met andere woorden, als je gebruikmaakt van een latere versie van PHP, dan zal jouw website efficiënter worden en minder resources nodig hebben om dezelfde bewerkingen uit te voeren.

Twee keiharde redenen om aan de slag te gaan met het omschakelen naar een nieuwere, snellere en beter ondersteunde PHP versie!

Haken, ogen, en compatibiliteit

Wellicht roepen de bovengenoemde argumenten een logische vraag op: “Waarom zetten jullie dan niet standaard alle pakketten over op PHP 5.5, als het zo veel beter is?”

Dat is een goede vraag! Het antwoord heeft te maken met het enorme scala aan websites dat klanten op ons platform hosten en de compatibiliteit. Er verandert namelijk wel iets in de functionaliteit van PHP, wanneer een nieuwe versie wordt uitgebracht. Het is natuurlijk niet de bedoeling dat wij, als webhostingprovider, zomaar ineens de PHP-versie van jouw pakket omschakelen, waarna jouw website het niet langer zou doen. Simpel gezegd, als iemand bewust voor een PHP-versie heeft gekozen, dan willen we die niet zomaar wijzigen. Echter, nieuwe klanten worden direct op PHP 5.5 gezet.

Zoals je zult begrijpen is dit één van de redenen waarom we gekozen hebben voor de implementatie van de PHP-selector. Omdat iedereen hiermee individueel kan bepalen wanneer hij of zijn overgaat naar een nieuwe versie, zonder dat hiervoor een grote platformbrede migratie nodig is. Sommige mensen willen direct de laatste versie, waar anderen iets uitgebreider willen testen of meer tijd nodig hebben.

Controleer je website!

Het is dus wel belangrijk om, voordat je de knop omzet, te controleren of jouw website of applicatie wel ondersteuning biedt voor het gebruik van de gekozen PHP versie. Echter, is hierin ook de PHP-selector een bron van grote flexibiliteit! Je kunt namelijk niet enkel de PHP-versie upgraden, maar ook downgraden.

Over naar PHP 5.5: testing!

Stel dus dat er onverwacht toch een probleem optreedt binnen de website, wanneer je naar PHP 5.5 overschakelt, dan kun je weer terugschakelen totdat je het probleem hebt kunnen oplossen. Ook kun je heen en weer schakelen om bijvoorbeeld onderdelen van jouw website te testen in een andere PHP versie. Zie bijvoorbeeld ook de appendices van PHP voor meer informatie over de verschillen en migraties tussen versies.

Wanneer je een populair CMS gebruikt, dan wordt vaak door de ontwikkelaars aangegeven welke PHP versies ondersteund worden. Zo kun je voor WordPress, Joomla en Drupal terugvinden dat de laatste versies van alle drie zonder probleem gebruik kunnen maken van PHP 5.5. Controleer echter ook of alle gebruikte plug-ins, modules en themes eveneens zijn bijgewerkt naar de laatste versie en dus ook compatibel zijn.

Kies de juiste versie

Als je een nieuw hostingpakket bij Antagonist afneemt, dan is hiervoor standaard PHP 5.5 ingeschakeld. Dit is dan ook de PHP versie die wij aanraden voor de meeste websites.

PHP 5.6 is op 28 augustus gelanceerd door de ontwikkelaars van PHP en is als ‘stable release’ aangemerkt. Deze versie is ook beschikbaar in de PHP-selector en kun je ook zonder enig probleem gebruiken, mits jouw website dit ondersteunt. Echter, zijn bepaalde PHP-encoders, zoals ‘Ioncube loader’ en ‘Zend guard loader’ nog niet beschikbaar voor deze versie.

Tof! Hoe maak ik gebruik van de PHP-selector?

Op dit moment is deze functionaliteit beschikbaar op al onze servers. Als je wilt overschakelen naar een nieuwere versie van PHP, bijvoorbeeld de aanbevolen versie PHP 5.5, dan kun je op de volgende manier doen.

Stap 1: Log in op DirectAdmin
Zie de handleiding ‘Hoe log ik in op DirectAdmin voor meer informatie over hoe je kunt inloggen op DirectAdmin.

Stap 2: Ga naar ‘Select PHP version’
Je vindt deze optie helemaal onderaan bij het kopje ‘Advanced Features’:

Over naar PHP 5.5: PHP versie selecteren

Stap 3: Kies de gewenste versie en klik op ‘set as current’
Nadat je een versie hebt ingesteld, kun je ook nog specifiek bepaalde PHP-modules in- of uitschakelen:

Over naar PHP 5.5: de PHP-selector van Antagonist

100% keuzevrijheid in PHP-versie en -instellingen

Zoals je ziet heb je dankzij deze nieuwe functionaliteit nu volledige controle over alle verschillende versies. Een nieuw hostingaccount krijgt vanaf nu standaard de meest recente stabiele versie van PHP. Natuurlijk adviseren we al onze klanten om te allen tijde de laatste stabiele versie van PHP te draaien. Zo ben je altijd verzekerd van de meest betrouwbare, veilige en snelle versie. Veel succes!

P.S. Wil je op de hoogte blijven van alle artikelen, updates, tips en trucs die verschijnen op ons blog? Dat kan! Rechts bovenin via RSS, e-mail, het liken van onze Facebook-pagina, het +1’en op Google+ of het volgen op Twitter.